This project has moved. For the latest updates, please go here.

OpenWeatherMap Layer

May 25, 2014 at 4:42 PM
Hi,

I tried to use a layer from OpenWheaterMap but it does not refresh correctly.

For that I simply add :
<map:TileLayer SourceName="OpenWeatherMap - Pressure" TileSource="http://undefined.tile.openweathermap.org/map/pressure_cntr/{z}/{x}/{y}.png"  />
in the wpf sample app.

The next image shows what I get :
Image
http://www.hostingpics.net/viewer.php?id=502379test.png

Images with différents zooms are mixed.

Thank
Coordinator
May 25, 2014 at 7:45 PM
Edited May 25, 2014 at 8:29 PM
Set the TileLayer's LoadLowerZoomLevels property to false. And please note that this is typically used as an overlay on top of another TileLayer, just like the OpenSeaMaps layer in the sample application.
May 26, 2014 at 5:57 PM
It works!

Happy holidays! And thank you for develop and maintain this control.
Nov 26, 2014 at 3:05 PM
I realise that this is an older post (that probably applies to an older version of the control) but I note there is no longer a LoadLowerZoomLevels property on the TileLayer class.

I am kind of reading between the lines here and making an assumption that, when the property was present, setting this true prevented the gradual introduction of the map detail (where the lower level images were displayed first and then replaced with the higher level details as they became available). If this is the case, is there a similar property elsewhere that can be used where this once was as I would prefer to simply display the zoom level I have selected for speed purposes.

Thanks.
Coordinator
Nov 26, 2014 at 5:16 PM
I removed that property for a lack of usefulness. If you want to change the behaviour, take a look at line 231 in TileLayer.cs.